Введение

Navigation: »No topics above this level«

Введение

 Return to chapter overview

BB5 Easy Service Tool - далее BEST предназначен для проведения сервисных операции с телефонами Nokia семейства BB5.


Возможности

Navigation: Введение >

Возможности

 Return to chapter overview

На данный момент (v1.02, 3rd public release) :

· Флэширование ( S40/S60 )
· Сохранение контента пользователя (Галлерея) ( S40/S60 )
· Сохранение SMS/MMS ( S40/S60 ) (В читаемом/текстовом виде*)
· Чтение/Запись Телефонной книги ( S40/S60 ) ( Поддержка новых S40*)
· Работа со значениями Life Timer'a (чтение/сброс/запись)
· Чтение/Запись календаря ( S40/S60 ) ( Вывод текстовой версии содержимого календаря S40 *)
· Чтение пароля карты памяти ( S40/S60 )
· Чтение телефонной книги с WD2 смартфонов
· Поддержка DCT4+ ( контент пользователя )
· Чтение/Запись РР ( Product Profile S40/S60 )
· Сброс настроек телефона
· Форматирование Файловой Системы
· Тестирование (SelfTest, adc, display test, keyboard)
· Чтение/Сброс Юзер кода (в зависимости от модели )
· Чтение/Запись РМ
· Чтение информации
· Редактирование специфических параметров телефона ( S40 Label )


Поддерживаемые модели

Navigation: Введение >

Поддерживаемые модели

 Return to chapter overview
· S40 – Все (3rd,5th ,6th edition’s)
· S60:

1. 7ое поколение : 3230,6260,6600... ( COM only )

Все модификации данных моделей.

2. 8ое поколение : 6630,6631,6680,6681,6682,N90,N70,N72.... ( COM/USB )

Все модификации данных моделей.

3. 9ое поколение : E50,E51,E60,E61,E61i,E62,E65,E66,E70,E71,N71,N73,N75,N76,N77,N80,N81,N81 8GB,N82,N91,N92,N93,N93i,N95,N95 8GB,N95 8GB NAM,N95 NAM,6110 Nav,6120c,6121c,6124V,6290,5500s,5700XM..... ( COM/USB )

Все модификации данных моделей.

4. Поколение Symbian 9.3 и 9.4 (5800,N78,N79,5230....) - поддержка сугубо тестовая (COM/USB )


Поддерживаемые интерфейсы

Navigation: Введение >

Поддерживаемые интерфейсы

 Return to chapter overview

· USB
· COM (FTDI,PL.... JAF/UFS и прочие в режиме Com-эмуляции)

Для большей стабильности и удобства в работе с программой в Fbus режиме рекомендуется использовать только FTDI/PL и прочие унибоксы/кабеля.

Настройка латентности ком-порта

Параметр 2 – в настройках является самым лучшим.

С версии 1.02 – BEST поддерживает JAF/UFS/прочие интерфейсы в режиме ком эмуляции лучше и стабильнее в плане сохранения данных.


Работа с программой

Navigation: »No topics above this level«

Работа с программой

 Return to chapter overview

Для запуска программы необходимо иметь активированную карту Infinity/ContentExtractorDongle и лицензию.


Запуск и первая настройка программы

Navigation: Работа с программой >

Запуск и первая настройка программы

 Return to chapter overview

Настройка заключается в следующем -

1. Необходимо выбрать директорию, в которой находятся установленные пакеты прошивок

2. Выбор соединения, с которым намереваемся работать - USB/COM

Больше ничего настраивать не нужно. Программа готова к работе.


Начало работы

Navigation: Работа с программой >

Начало работы

 Return to chapter overview

Для начала необходимо подключить телефон к выбранному интерфейсу.

Лучше всего в режиме LOCAL/TEST. Для USB режима нет никакой разницы - главное, чтобы телефон увиделся компьютером.

Как только видим в логе строчку :

Phone found!

Series XX Device detected!

read info... - Ok

Все - программа увидела телефон. Можно приступать к необходимым операциям.


Описание и значение кнопок

Navigation: Работа с программой >

Описание и значение кнопок

 Return to chapter overview

Вкладка Service Tool

· Read Info - Чтение информации о телефоне
· Check - проверка Flash ID, SD ключа, LiveTest.
· UserCode Read/Reset - Чтение/сброс юзер кода ( в зависимости от модели кнопки могут быть не активны )
· Read ASk - чтение ASK файла
· LifeTimer read/write/reset - Работа со значениями лайфтаймера ( чтение, сброс, запись )
· Product code read/write - Чтение/запись продукт кода телефона
· PM Read/Write - Чтение и запись Permanent Memory
· Factory Settings - Сброс выбранных типов настроек на заводские значения
· ProductProfile Read/Write - Чтение/запись полного продукт профиля (S60/S40)

Вкладка User Data Tool

· Read PhoneBook - Чтение телефонной книги SmartPhone S60 / S40
· Write PhoneBook - Запись телефонной книги SmartPhone S60 / S40
· Read Calendar - Чтене календаря SmartPhone S60 / S40
· Write Calendar - Запись календаря SmartPhone S60 / S40
· Read MMC Password - Чтение паролей карты памяти SmartPhone S60 / S40
· Save Gallery - Сохранение всего пользовательского контента ( мелодии, картинки и прочее ) SmartPhone S60 / S40
· Save SMS/MMS - Сохранение всех сообщений пользователя SmartPhone S60 / S40

Вкладка Misc

· Format - Форматирование файловой системы ( автоматическое, не затрагивает юзер-диски на s40 [1gb] / s60 [4,8...gb] )
· ADC Read - Чтение параметров потребления, напряжения акб
· SelfTest - Тестирование, с расширенным инфо-логом
· NCK enter - Ввод NCK кода
· Display Pattern Test - Тестирование LCD
· Keyboard test - Тестирование клавиатуры
· FunLabel - Редактирование меток ( S40 по коду *#0010# пишем все, что душе угодно ( пока только латиница поддерживается / s60 по коду *#06# в скором времени )

Вкладка Flashing

Собственно данная вкладка предназначена для прошивки.

На данный момент поддерживаются S40 телефоны в режимах Normal и DEAD USB.


Операции и функции

Navigation: Работа с программой >

Операции и функции

 Return to chapter overview

После запуска программы необходимо выбрать интерфейс, с которым будем работать.

Программа запоминает последний выбранный интерфейс и выбирает его при следующем запуске автоматически.

После выбора интерфейса подключаем к нему телефон.

Есть два варианта :

· подключение телефона в любом из режимов – Test/Local/Normal
· DEAD USB

1. В первом варианте нужно просто подключить телефон.

Как только BEST найдет телефон – все доступные для данного телефона возможности станут активны.

2. Во втором варианте :

Для мертвых телефонов необходим режим - DEAD USB.

Во вкладке Flashing необходимо отметить галочку DEAD USB

После остается выбрать файлы прошивки и нажать кнопку FLASH и после подключить телефон, коротко нажав кнопку включения. Если операция флэширования прошла успешно – телефон будет переведен в TEST режим и программа будет ожидать дальнейших команд пользователя.

После подключения телефона можно приступать к выполнению необходимых операций.

Все операции производятся без каких-либо настроек/опций и прочего. Нажали кнопку – получили результат.


Сохранение данных

Navigation: Работа с программой > Операции и функции >

Сохранение данных

 Return to chapter overview

BEST прекрасно вытаскивает данные из моргаликов и висяков на заставке и прочих проблемных телефонов.

На данный момент, возможно вытащить все разновидности юзер данных из большинства BB5 телефонов/смартфонов. Таких, как :

· Телефонная книга
· Календарь
· Пароли карт памяти
· Контент (Галерея) ( фотографии, записи диктофона, картинки и прочие файлы, находящиеся в пользовательской памяти )
· SMS/MMS сообщения

Извлечение контента (галереи) юзера возможно на всех BB5 ( смартфоны/телефоны ).

Извлечение SMS/MMS, Телефонной книги, Календаря, Паролей карт памяти возможно на следующих телефонах:

· Серия 40 ( Series 40 – обычные телефоны ) – Поддерживаются ВСЕ S40 телефоны.
· Серия 60 (Series 60 – Смартфоны ) – Поддерживаются следующие модели/серии:

1. Symbian 8.X : N70, N72, 6680, 6681 и остальные BB5 телефоны на этой платформе, а так же все их модификации.
2. Symbian 9.1,Symbian 9.2 : E50,E51,E60,E61,E61i,E62,E65,E70,E71,N71,N73,N75,N 76,N77,N80,N81,N81 8GB,N82,N91,N92,N93,N93i,N95,N95 8GB,N95 8GB NAM,N95 NAM,6110 Nav,6120c,6121c,6124V,6290,5500s,5700XM и многих других, а так же все их модификации.
3. Symbian 9.3/Symbian 9.4 : в разработке.

Но, можно пробовать и сейчас. Есть шанс, пусть и небольшой, вытащить телефонную книгу удачно.

4. Так же, дополнительно – поддерживаются старые смартфоны на платформе WD2 (Symbian 7.x ) - 3230, 6600, 6260, 7610, 6670 а так же всех их модификации.

Все операции по сохранению юзер контента/данных можно проводить как по USB так и по Fbus интерфейсам. Fbus рекомендуется использовать в случае неработоспособности USB интерфейса.

Общие моменты

Для успешного извлечения данных из телефона необходимо, чтобы он мог быть определен программой по одному из интерфейсов – USB/COM. И есть некоторые моменты для S40/S60 в отдельности – о них чуть ниже.

Если программа увидела его – можно выбрать желаемую операцию – если это Телефонная книга, календарь, или пароли карт памяти – программа предложить выбрать имя и место сохраняемого файла, после чего программа извлечет выбранный тип данных.

Если это Галерея ( Save Gallery ) или SMS/MMS ( Read SMS/MMS ) – программа сделает все сама – необходимо лишь дождаться завершения операции. Данные будут сохранены в корне программы, в новой папке, которая будет иметь имя – IMEI текущего телефона.

Необходимо вытащить, если стоит, карту памяти. Этот момент очень важен!

В некоторых случаях, возможно – необходимо флэширование MCU / MCU+PPM частей прошивки для запуска телефона. Флэширование контента ( CNT ) уничтожит все данные. Восстановить их будет невозможно.

Прошить любой s40 телефон в режиме DEAD/Normal можно ( даже нужно ;) ) с помощью BEST’a.

· S40

Если необходимо вытащить данные из S40 телефона – необходимо лишь два условия –

1. Телефон должен видеться программой
2. Телефон не был прошит/стерт/не производились сбросы ( User, Full Factory )

Если в телефоне есть данные – программа извлечет их без проблем.

· S60

Для смартфонов существует еще несколько ограничений

1. Смартфон должен видеться программой
2. Необходимо, чтобы смартфон имел исправную аппаратную часть – СМТ/APE.

( Это в принципе особо важно для старых смартфонов, вроде N70 и ему подобных )

3. Для Телефонной, календаря, паролей, sms – гарантируется успешное извлечение полностью поддерживаемых моделей ( список указан выше ). Не поддерживаемые модели – тестировались лишь частично. Поддержка остальных будет в ближайшее время.

Возможные проблемы/советы при извлечении/восстановлении данных :

· S40

Как таковых – проблем нет. Если в телефоне есть файлы/данные – программа их вытащит.

1. Телефонная книга

Если в телефоне есть книга – программа извлечет ее. Никаких проблем здесь нет.

Поддерживается кросс-запись телефонной книги из телефона в телефон между всеми телефонами серии 40. Можно так же объединять несколько телефонных книг из разных телефонов в одну – методом записи файлов в телефон по очереди. Телефонная книга дописывается. Ограничения – лишь свободное количество слотов в телефонной книге.

2. Календарь

Для S40 3его поколения ( 6233 и ему подобные ) – программа предлагает выбрать место сохранения файла. Формат текстовый – внутри все записи из календаря в обычном, текстовом виде.

Для S40 5ого и 6ого поколения ( 6303, 5610, 6500с и прочих ) – программа предложит сохранить файл EVENT – данный файл можно восстановить обратно в телефон. Поддерживается кросс-запись из телефона в телефон, просмотр содержимого. Так же, вместе с данным файлом будет создан текстовый файл, в котором будет содержаться содержимое календаря в обычном, текстовом виде.

Собщения:

Calendar is totaly clear... :( и Calendar is not present in PM :( -значат, что календарь пуст.

3. Пароли карт памяти

Если в телефоне были установлены пароли на карту памяти – программа покажет их список в логе и сохранит в папке Backup РМ-файл с именем - Name_IMEI_MMC_password_record.pm

Данный файл можно будет записать назад, если это будет необходимо, как обычный РМ – кнопкой Write PM.

Если паролей не найдено – программа сообщит - password not set :( .

Так же пароли карт для s40 сохраняются автоматический при прошивке в нормал-режиме.

4. Галерея/смс

Возможно, если попадутся битые/поврежденные файлы – программа и пропустит их, сообщив в логе -

Error while reading file! Attempt to continue...

· S60

Самым важным моментом является запуск файловой и работоспособность АРЕ части.

1. Телефонная книга

Если телефон входит в список поддерживаемых – то в данном случае проблем нет. Телефонная книга будет извлечена. Далее можно записать ее обратно в телефон по завершению восстановительных операций, либо отослать нам для извлечения данных. Автоматическая возможность сохранения стандартных вариантов будет в скором времени.

В случае, если телефон не входит на данный момент в список поддерживаемых – то можно пробовать извлечение. Если оно пройдет неудачно – необходимо сообщить модель, RM, версию SW и сам лог на форуме поддержки.

Восстановление телефонной книги может быть произведено в тот же телефон, из которого она была извлечена, либо можно записать книгу в любой рабочий телефон, который входит в список поддерживаемых.

Кросс-запсь поддерживается меду Symbian 8.X и Symbian 9.1/9.2 .

Внимание – запись новой телефонной книги в смартфонах – удаляет старые данные – программа напомнит вам об этом при записи, и спросит дальнейшие действия.

В некоторых случая – телефонная книга оказывается поврежденной – если после записи книги в телефон – он зависает при включении – значит повреждена именно она. Необходимо в данном случае отослать бэкап нам для извлечения. Возможность будет встроена в программу в скором времени.

2. Календарь

Для календаря условия и моменты те же, что и для телефонной книги.

3. Пароли карт памяти

Пароли карт памяти сохраняются в отдельный файл и выводятся в лог в случае, если они присутствуют в телефоне. Моменты те же, что и для телефонной книги. Запись паролей обратно не возможна.

4. Галерея/смс

Извлечение галереи не ограничено версией телефона. Программа поддерживает все смартфоны. При возникновении каких-либо проблем – сообщить модель, RM, версию SW и сам лог на форуме поддержки.

Сообщение- Error on CS packet! Skipping... говорит о наличии поврежденного файла.

· WD2 смартфоны и телефонная книга

Данная функция включена в программу, хоть и WD2 совершенно другие.

Для вытаскивания телефонной книги необходимо :

· Подключить телефон по COM/Fbus интерфейсу.
· Принудительно (нажатием кнопки включения ) включить телефон.

В тестах использовался UFS кабель от 3230 и самодельный переходник для коробки Infinity.

Как только программа определит телефон – станет доступна всего одна кнопка –

Read phonebook.

Нажимаем ее. Выбираем - куда сохранить файл.

Начинается процесс сканирования. Вот здесь и начинается самое интересное.

Ошибка

Error! Try again few times, please

If still no luck - Repower phone and try restart procedure....

If still no luck - looks like FS damaged or clear... :(

Может означать следующее :

1. Инициализация файловой не прошла – пробуем прочитать еще раза три-четыре подряд. В ряде случаев этого бывает достаточно.
2. Необходимо попробовать переподключить телефон (полностью отключив питание)
3. Возможно, что телефонной книги там нет – она старта/повреждена полностью.
4. Возможно – повреждена файловая система – если телефон имеет ошибку Startup Failed. Contact retailer – это вероятнее всего. В данном варианте телефонную книгу спасти нереально почти. Возможно, если будет необходимость – в будущем будет проведена работа по решению этой проблемы.

В большинстве случаев телефонная книга читается успешно. Так же, иногда, необходимо прошить MCU+PPM. Без сбросов и форматирования.

После успешного извлечения необходимо отослать телефонную книгу нам для извлечения данных. Возможность будет встроена в программу в скором времени.

Функция извлечения протестирована на нескольких 3230 и 7610 – во всех случаях извлечение прошло успешно.

· S40 lite ( DCT4 + )

С версии 1.02 в BEST добавлена поддержка DCT4+ телефонов.

Интерфейс, естественно – COM.

Возможности :

· Сохранение контента пользователя
· Сохранение смс/ммс
· SelfTest, ADC,FunLabel

На данный момент поддержка сугубо тестовая.

В следующих версиях работа с DCT4+ будет кардинально улучшена.


Прошивка

Navigation: Работа с программой > Операции и функции >

Прошивка

 Return to chapter overview

На данный момент BEST поддерживает флэширование S40/S60 телефонов в обоих режимах –

1. Normal ( normal/test/local mode )
2. DEAD

Выбор файлов – ручной и автоматический – при наличии установленного полного пакета прошивки.

S40 :

Можно прошивать следующие комбинации файлов :

· MCU
· MCU+PPM
· MCU+CNT
· MCU+PPM+CNT

Для успешной прошивки в DEAD режиме необходимо :

1. Выбрать корректную версию файлов прошивки ( RM для автоматического режима )
2. Отметить галку DEAD USB, выбрать опции пост-прошивочных действий.
3. Нажать кнопку FLASH и после – подключить телефон и нажать коротко кнопку включения. Некоторые телефоны необходимо просто подключить к кабелю ( 7900 и подобные )
4. Дождаться завершения прошивки
5. После прошивки телефон будет находиться в TEST режиме. Можно будет приступить к операциям сохранения/восстановления.

Для успешной прошивки в нормальном режиме необходимо :

Для начала – понятие нормальный – включает в себя все режимы – Normal/Test/Local.

1. Выбрать корректную версию файлов прошивки (Если Manual не отмечен – и установлен пакет прошивки – программа сама выберет файлы )
2. Нажать FLASH и дождаться завершения процесса прошивки.
3. После прошивки телефон будет находиться в TEST режиме. Можно будет приступить к операциям сохранения/восстановления.

P .S.

Во время процесса прошивки можно изменять опции – а именно – отменить флэширование еще не обработанных файлов – просто сняв галку с нужного пункта.

Флэширование S40 протестировано в обоих режимах на более уже чем 50ти телефонах разных моделей ( 5300, 5200, 3610, 7310, 7210c, 6500c, 6500s, 5610, 6300, 6303, 5310, 5130, 3120c, 6233, 6280, 6270, 6085 и прочих ) - нет никаких проблем.

S60 :

Можно прошивать следующие комбинации файлов :

· MCU
· PPM
· CNT
· ENO
· APE
· MCU+PPM
· MCU+CNT
· MCU+PPM+CNT

Если говорить проще – можно шить в любом количестве и в любых комбинациях.

Режимы :

1. DEAD
2. Normal

Правила и необходимы шаги аналогичны прошивке S40 – выбираем файлы, шьем. Никаких отличий больше нет.

Так же для S60 добавлен режим перевода из DEAD режима в TEST ( для телефонов, поддерживающих DEAD режим ). Необходимо выбрать корректную версию прошивки ( в принципе это не так важно – главное чтобы файлы прошивки соответствовали RM телефона ) и сняв все галочки напротив всех файлов нажать FLASH. Программа запустит телефон в LOCAL\TEST режиме. Режим не принципиально важен, так, как сохранение данных можно производить в любом из режимов.

Поддерживаемые на данный момент телефоны :

· X6,N86,N85,N76,N77,N78,N79,N75,N97,5800,5230,5530,6120c,6124c,6110n,6210n,E71,E75,6290,N81,N81-8gb,E51,6220c,6650d,5800i,N97mini,E66,E63,3250,E50,5500s и другие, а так же все модификации и RM-версии данных моделей.

Поддержка остальных будет добавлена в ближайшее время.


Другие возможности

Navigation: Работа с программой > Операции и функции >

Другие возможности

 Return to chapter overview

В список прочих возможностей входят :

· Read Info - Чтение информации о телефоне
· Check - проверка Flash ID, SD ключа, LiveTest.
· UserCode Read/Reset - Чтение/сброс юзер кода ( в зависимости от модели кнопки могут быть не активны )
· Read ASk - чтение ASK файла
· LifeTimer read/write/reset - Работа со значениями лайфтаймера ( чтение, сброс, запись )
· Product code read/write - Чтение/запись продукт кода телефона
· PM Read/Write - Чтение и запись Permanent Memory ( Skip 120/308 Пропускает данные блоки при записи )
· Factory Settings - Сброс выбранных типов настроек на заводские значения
· ProductProfile Read/Write - Чтение/запись полного продукт профиля (S60/S40)
· Format - Форматирование файловой системы ( автоматическое, не затрагивает юзер-диски на s40 [1gb] / s60 [4,8...gb] )
· ADC Read - Чтение параметров потребления, напряжения акб
· SelfTest - Тестирование, с расширенным инфо-логом
· NCK enter - Ввод NCK кода
· Display Pattern Test - Тестирование LCD
· Keyboard test - Тестирование клавиатуры
· FunLabel - Редактирование меток ( S40 по коду *#0010# пишем все, что душе угодно ( пока только латиница поддерживается / s60 по коду *#06# в скором времени )

Большая часть возможностей не составит никакого труда для освоения и понимания.

· SelfTest работает по USB/COM. Нет никаких настроек и прочего - все параметры тестируются сразу. Выводятся в лог и после в таблице - если есть какие-то проблемы - выводится небольшая подсказка по возможному устранению. Подсказки собраны исключительно из Нокиевских документов.

P.S. : Будем рады любым дополнениям и уточнениям для улучшения информативности SelfTest'a.

· LifeTimer, ADc, сбросы, работа с РМ, NCK ввод затруднений в использовании не вызовет.
· Format - Форматирование автоматическое. Не нужно выбирать диски и что-то делать. Программа сама сканирует их и форматирует только системные/сваповые. Юзер диски не затрагиваются. Для S40 с внешней памятью на борту программа спрашивает о форматировании этого диска.
· Keyboard test - проверяет состояние клавиатуры и выводит, если есть проблема, после завершения теста, список кнопок и их статусы. Тестирование можно проводить двумя способами - нажать KeyB Test и через пару секунд нажать Finish Test - если тест прошел успешно и нет ни одной зажатой кнопки - счетчик кнопок будет 0. Если что-то замыкает - программа подскажет - какая именно кнопка. Второй метод - начать тест - нажать нужные кнопки и после завершения теста в логе посмотреть - все-ли они были нажаты.
· Fun Label - редактирование метки по коду *#0010# для S40 телефонов.

Создайте текстовый файл. Обзовите его как душе угодно, и смените расширение на .s4lbl. В файле можно писать что угодно, на данный момент поддерживается только латиница при написании, пробуем добавить мультиязычность.

После записи файла при вводке кода с клавиатуры *#0010# будем видеть то, что вписали.